[icq-devel] ICQ Authorization



Christian Ehrlicher Ch.Ehrlicher at gmx.de
Tue Mar 16 20:32:13 CET 2004


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I had also such problems, but I don't know if this relates to you:

I could send an auth request to the user. The user gets them and
accepts. But then I didn't got any response from the server.
After some investigation, I recognized, that this user accepted an
auth request a long time ago, but the icq-client somehow missed this.
And a second auth grant didn't goes through the server because the
server thinks you already got this response. But this is only my point
of view - don't know if this is right
You can see if you were authorized on logon process -->
http://iserverd.khstu.ru/oscar/snac_13_06.html and
http://iserverd.khstu.ru/oscar/ssi_item.html
When [TLV(0x0066), itype 0x00, size 00] isn't there, you are authorized.

HTH
Christian

ander Basunov schrieb:

> Hello,
>
> I have a problem with authorization request in ICQ. My client sends
> SNAC(13,18) with UIN and reason. Another client (icq2003a) receives
> the request. 1) If the client declines the request, my clone
> receives SNAC (13,1B) - everything is fine. 2) If the client
> accepts the request, THERE IS NO RESPONSE from server and the clone
> receives nothing. - this is the problem! Does anybody know why ?
>
> I have a suggestion, that it may depend on capabilities requests or
>  something... Is it of any sense ?
>
> Thanks for help.
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2-rc1-SuSE (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFAV1Y8nNKwkgf+zVMRApF3AKCFra0r0pb31W5lQt0o6GH0AkvW0ACfRQu3
ZnTxWMmorrABS8ad6+rgIaE=
=ammX
-----END PGP SIGNATURE-----




More information about the icq-devel mailing list