[icq-devel] Message type



Remy Lebeau gambit47 at yahoo.com
Tue May 27 19:34:13 CEST 2003


--- Rüdiger Kuhlmann
<icq-list-oWUpAQCWC2r4 at ruediger-kuhlmann.de> wrote:

> Y'know, you may be right. However, the CSS
> files I use don't have a \r, but a \n in them

Wrong.  I downloaded your CSS files as-is directly
from your site unmodified, and they did indeed use CR
for their line breaks, not LF.

> and what you're saying is that all CSS files with
> Windows CR/LF pairs is invalid because or the CR.

I am merely saying that CR is not a valid character
according to the CSS specs.  How Windows-based
browsers decide to deal with CRLF, since CRLF is the
standard line-break sequence under Windows, is up to
the individual browser to decide.

> I don't know how you come to the conclusion that
> there would be CR/LF pairs in my file, because
> there aren't.

I never said there was.  Your files are using CR only.
 It was earlier suggested that using IE to save the
files to local disk would cause the CR to be
automatically replaced with CRLF instead in the local
file.  Which they were, and thus everything started
working correctly when viewed locally.

You really should consider going back to your original
files and changing them to use LF instead of CR in
order to be compliant with the CSS specs, which I get
the feeling you are trying to be big on doing.


Gambit

P.S. I can no longer acces your site at the moment in
general, it is returning a "Database Error" message on "connect".

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com


More information about the icq-devel mailing list