[icq-devel] Receiving Snac(0x04, 0x0A)



Fabrice Michellonet fabrice.michellonet at wanadoo.fr
Sat Nov 23 16:31:58 CET 2002


Hi everybody,

seems this list is quite silent those last days... is this a winter effect ? ;-P
But i need your help once more time.

When i send (with Miranda or Trillian) messages that contains more than 410 char, i receive a Snac(0x04, 0x0A). This snac is called "Missed call" in the Oscar Documentation.
I've tried to send the same message(>410 char) to a miranda or trillian clone; they receive  the message with no problem.

I've had a look on http://www.stud.uni-karlsruhe.de/~uck4/ICQ/ but i didn't find anything about that Snac.

So, my question is why do i receive this snac and other clones don't ? Do i have to send some special paquet or a capability ?

Anyway here is the dump of the snac i've received and what i understand in it.

2A 02 4D 0C 00 3B 
    00 04 00 0A 00 00 94 36 ED 93 
      00 02                         // missed msg-type ??
      08 34 38 37 31 30 37 36 34    // sender's BUIN [48710764]
      00 00 00 04 00 01 00 02       // TLV(0x00) always 0x00010002
      00 50 00 06 00 04 20 00 01 00 // TLV(0x50) always 0x000420000100
      00 0F 00 04 00 00 00 10       // TLV(0x0F) ???
      00 03 00 04 3D DE 6B 2B       // TLV(0x03) ???
      00 02 00 02                   // also seen 0x00020001

any clues ?

regards,

Fabrice
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://vic20.blipp.com/pipermail/icq-devel/attachments/20021123/8a35a1e6/attachment.htm 


More information about the icq-devel mailing list