[icq-devel] Why won't my cookie ever work for me????



Remy Lebeau gambit47 at yahoo.com
Sat Mar 23 03:00:22 CET 2002


Sorry, still having the same problem.  I even took out the CLI_GOODBYE
packet, and switched the sequence number from Little Endian to Big Endian
(as I notice the server using after all, and Massimo's docs says it is
that), and it still won't work.  I also notice the server starting with
fresh sequence numbers from the second server, but I guess that's to be
expected, huh?

I've attached my latest hex dump.

It can't possibly this hard to do, it's such a simple concept.  What the
hell am I missing?????


Gambit

BTW, I just installed Ethereal finally.  Now I just have to learn how to use
it, hehe

----- Original Message -----
From: "Daniel Tan" <datan at seas.upenn.edu>
To: <icq-devel at blipp.com>
Sent: Friday, March 22, 2002 5:22 PM
Subject: Re: [icq-devel] Why won't my cookie ever work for me????


> ok, I compared it with the FLAP's of my own client.
>
> 2A 01 28 D7 00 83 [log in with password]
> ...disconnect from server & connecting to second server
> 2A 01 28 D8 01 08 [log in with cookie]
>
> these are your FLAP's:
> 2A 01 01 5A 00 85 [log in with password]
> 2A 04 01 5B 00 00 [disconnect from primary server]
> 2A 01 69 71 01 08 [log in with cookie]
>
> the sequence number of your FLAP's have to follow from
> the primary server. ie. 01 5C

-------------- next part --------------
A non-text attachment was scrubbed...
Name: hex.dmp
Type: application/octet-stream
Size: 3718 bytes
Desc: not available
Url : http://vic20.blipp.com/pipermail/icq-devel/attachments/20020322/5f24d973/attachment.obj 


More information about the icq-devel mailing list