[icq-devel] disabling remote direct connections



rad2k rad2k at mail.ru
Tue Jun 11 01:05:13 CEST 2002


okie, again. The solution was to clear ALL fields inside the 0xc TLV.
Even if i had the version in 0x01 or whatever, clearing all fields solved the problem.


On Mon, 10 Jun 2002 15:59:29 -0300
rad2k <rad2k at mail.ru> wrote:

> it seems the TCP Flag if it isn't set to 0x04 should disable direct connections to this client.
> but even if i set it to 0x01 for Firewall or whatever setting other than 0x04, the Windows icq
> client tries to connect to the client's external ip Address:port
> 
> It's not paying attention to the TCP flag, thats what it seems.
> 
> Anyone has had the same problem?
> 
> rad2k
> -
> 
> On Mon, 10 Jun 2002 00:05:22 -0300
> rad2k <rad2k at mail.ru> wrote:
> 
> > hey,
> > 
> > I'm having a problemo here, whenever an icq200x is sending me a message, it just hangs
> > waiting to connect to me, when i really never binded a port. I don't want any clients
> > to try any direct connection against me, but i still need to have the 0xc0 tlv in my status
> > since i want to connect to other clients.
> > 
> > does anyone know how to do this? if its an unknown flag in the TCP field inside the 0xc0 TLV
> > or maybe a status flag?
> > 
> > take care
> > 
> > rad2k
> > -
> > -------------------------------------------------
> > icq-devel - The forum for ICQ protocol discussion
> > For unsubscribe and other mailing list info, see:
> > http://www.d.kth.se/~d95-mih/icq/icq-devel/
> > 
> > 
> -------------------------------------------------
> icq-devel - The forum for ICQ protocol discussion
> For unsubscribe and other mailing list info, see:
> http://www.d.kth.se/~d95-mih/icq/icq-devel/
> 
> 



More information about the icq-devel mailing list